Chrome .92 version upgrade impacting ServiceMax application
Incident Report for ServiceMax
Resolved
Please be advised that Salesforce have implemented a fix for the Chrome 92 issue. Salesforce have pushed a patch to all Orgs. You can confirm that your org has been patched by checking on https://status.salesforce.com. The org should show that Summer 21’ patch 14.5 has been applied.

Should you still see the issue, please clear cache and try again. Further information can be found in the updated KI from Salesforce - https://trailblazer.salesforce.com/issues_view?id=a1p4V000002BRMXQA4
Posted Jul 30, 2021 - 14:38 UTC
Identified
With Chrome .92 version upgrade, impact is seen when trying to delete ServiceMax Admin Setup configurations and during Service report generation with Signature configured when using Salesforce Lightning screens. Full detail and a work around is available on our Community Kitchen https://community.servicemax.com/s/article/Announcement-Known-Issue-with-Chrome-92-Version-Upgrade
Posted Jul 27, 2021 - 18:27 UTC
This incident affected: Critical Announcements.